IAD Region: degraded performance
Resolved
IAD is back to normal operations. This has been identified as a short DDOS attack that has now ceased.
Posted 22 days ago. Oct 26, 2018 - 16:27 UTC
Update
We are continuing to investigate this issue.
Posted 22 days ago. Oct 26, 2018 - 16:15 UTC
Investigating
The SecureAnywhere® DNS Protection is currently experiencing degraded performance. Customers may notice slower than usual DNS resolution times in the IAD region. We are investigating the issue and will have an update or resolution ASAP.
Posted 22 days ago. Oct 26, 2018 - 16:15 UTC
This incident affected: DNS Protection.