Webroot DNS Protection (legacy) | London | Latency
Resolved
We are confident the issue is resolved.
Posted 18 days ago. Oct 01, 2019 - 12:03 UTC
Monitoring
Latency has returned to normal. We're monitoring the service closely and will continue to do so until we're confident the issue is resolved.
Posted 18 days ago. Oct 01, 2019 - 09:58 UTC
Investigating
We are currently investigating an issue causing high latency in Europe/London.

This is only affecting the legacy version of the product. If you've migrated to the newer version, hosted on Google Cloud, you will be unaffected.
Posted 18 days ago. Oct 01, 2019 - 09:29 UTC
This incident affected: DNS Protection.