Degraded Performance Webroot Mobile backend
Resolved
This incident has been resolved.
Posted 15 days ago. Nov 02, 2018 - 16:38 UTC
Investigating
Webroot Mobile backend (Strada) is currently experiencing decreased performance. We are investigating the issue and working on a speedy resolution. Thank you for your patience.
Posted 15 days ago. Nov 02, 2018 - 13:54 UTC
This incident affected: Mobile Protection.