SecureAnywhere DNS Protection Latency in Hong Kong, Seattle, and Dallas Regions
Resolved
DDoS attack has subsided. Traffic is now routed back to Hong Kong, Seattle, and Dallas regions
Posted Jun 19, 2018 - 17:34 UTC
Investigating
We are current experience high traffic resembling a denial of service attack. Traffic in impacted regions, Hong Kong, Seattle, and Dallas have been re-directed to nearest available regions. Users may experience slight increase in latency.
Posted Jun 19, 2018 - 16:23 UTC
This incident affected: DNS Protection.