SecureAnywhere DNS Protection - Service is Degraded in US East Regions
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 12, 2018 - 22:51 UTC
Investigating
We are currently experiencing technical issues with our 3rd party service provider. Users will experience degraded performance in the US East regions.
Posted about 1 month ago. Nov 12, 2018 - 19:46 UTC
This incident affected: DNS Protection.