Degraded Performance | DNS Protection
Resolved
This issue is now resolved. Apologies for any inconvenience caused.
Posted Nov 04, 2019 - 14:41 UTC
Update
This issue is current affecting both legacy and Google Cloud users.
Posted Nov 04, 2019 - 14:25 UTC
Investigating
Webroot DNS Protection is currently experiencing decreased performance in North America. We are investigating the issue and working on a speedy resolution. Thank you for your patience.
Posted Nov 04, 2019 - 14:21 UTC
This incident affected: DNS Protection.