Webroot SecureAnywhere DNSP-Protection - Degraded Service in US Central/Chicago Region
Resolved
This incident has been resolved.
Posted 30 days ago. Mar 19, 2019 - 19:43 UTC
Investigating
We are experience degraded service due to possible DDoS attack.
Posted 30 days ago. Mar 19, 2019 - 19:38 UTC
This incident affected: DNS Protection.