SecureAnywhere DNS Protection - Service is Degraded in US East Regions
Resolved
We have resolved the networking issues with our 3rd Party service provider.
Posted 5 months ago. Oct 23, 2018 - 17:03 UTC
Investigating
We are currently experiencing technical issues with our 3rd party service provider. Users will experience degraded performance in the US East regions.
Posted 5 months ago. Oct 23, 2018 - 16:20 UTC
This incident affected: DNS Protection.