Degraded Performance Webroot Mobile backend (Strada)
Resolved
This incident has been resolved.
Posted 11 days ago. Nov 06, 2018 - 18:01 UTC
Identified
Webroot Mobile backend (Strada) is currently experiencing decreased performance. We are investigating the issue and working on a speedy resolution. Thank you for your patience.
Posted 12 days ago. Nov 05, 2018 - 16:45 UTC
This incident affected: Mobile Protection.