DNSP Degraded Performance
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 07, 2019 - 23:58 UTC
Update
We are continuing to work on a fix for this issue.
Posted 12 days ago. Jun 07, 2019 - 23:57 UTC
Identified
As of 3:30PM MST, customers may experience higher than normal DNS resolution latency. We have identified the issue, and working to correct the problem.
Posted 12 days ago. Jun 07, 2019 - 21:52 UTC
This incident affected: DNS Protection.