SecureAnywhere DNS Protection - DDoS attack in US-Central regions
Resolved
This incident has been resolved.
Posted 12 days ago. Oct 07, 2019 - 20:29 UTC
Investigating
We are currently working with third party service provider to mitigate DDoS attack in US Central regions. DNS-P Network based users will experience degraded performance.
Posted 12 days ago. Oct 07, 2019 - 19:41 UTC
This incident affected: DNS Protection.