SecureAnywhere DNS Protection - Service degraded In Toronto Region
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 20, 2019 - 22:57 UTC
Investigating
We currently experiencing degraded service in the Toronto region.
Posted 3 months ago. Feb 20, 2019 - 17:28 UTC
This incident affected: DNS Protection.