DNS Protection service interruption- All Regions

Resolved

The issue with Google Cloud Service has been resolved.
Posted Nov 16, 2021 - 20:39 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 18:55 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 18:54 UTC

Monitoring

Google Cloud Service interruption which, according to Google should be partially resolved
Posted Nov 16, 2021 - 18:53 UTC

Investigating

We are currently experiencing a global DNS Protection service interruption. This corresponds to Google Cloud Service interruption which, according to Google, should be partially resolved. The issue was first observed at 9:53am PST. We will provide more information as it becomes available.
Posted Nov 16, 2021 - 18:53 UTC
This incident affected: DNS Protection.