DNS Protection | Degraded Performance in US East
Resolved
This issue has been resolved.
Posted Oct 28, 2019 - 14:15 UTC
Investigating
Webroot DNS Protection is currently experiencing decreased performance in US East. We are investigating the issue and working on a speedy resolution. Thank you for your patience.
Posted Oct 28, 2019 - 13:25 UTC
This incident affected: DNS Protection.