SecureAnywhere DNS-Protection - APAC 45.54.55.54 and 45.54.55.55 is Down
Resolved
SecureAnywhere DNS-P service has been restored to APAC region
Posted 3 months ago. Sep 01, 2018 - 02:47 UTC
Investigating
We are currently experiencing issues with our service provider and are working to quickly resolve this issue.
Posted 3 months ago. Sep 01, 2018 - 02:37 UTC
This incident affected: DNS Protection.