Webroot DNS Protection | US East | Degraded performance
Resolved
This incident has been resolved.
Posted about 2 months ago. Apr 10, 2019 - 17:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Apr 10, 2019 - 16:43 UTC
Investigating
We are currently investigating the issue. Customers might experience slight latency.
Posted about 2 months ago. Apr 10, 2019 - 15:43 UTC
This incident affected: DNS Protection.