SecureAnywhere DNS Protection - US West region maintenance
Resolved
Our third party service provider has fixed the issue on their side. Service has been fully restored.
Posted 23 days ago. Sep 26, 2019 - 14:36 UTC
Identified
Third party maintenance has encountered unforeseen issues. We are working with them to resolve the issue. APAC regions may experience increased latency as traffic has been re-routed to alternate regions.
Posted 23 days ago. Sep 26, 2019 - 04:03 UTC
This incident affected: DNS Protection.