WSAT Performance Degradation
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 17:04 UTC
Identified
Email delivery is currently experiencing slow and intermittent performance. Fix and testing is in progress.
Posted Mar 12, 2024 - 20:05 UTC
This incident affected: Security Awareness Training.