DNSP - Chicago region POP is currently down.
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 12, 2019 - 19:22 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Feb 12, 2019 - 19:05 UTC
This incident affected: DNS Protection.