Degraded Performance SecureDNS
Resolved
This issue has been resolved.
Posted Feb 18, 2020 - 14:45 UTC
Investigating
SecureDNS is currently experiencing decreased performance in North America. We are investigating the issue and working on a speedy resolution. Thank you for your patience.
Posted Feb 18, 2020 - 14:29 UTC
This incident affected: DNS Protection.