SecureAnywhere SecureDNS Protection EU Region is currently experiencing degraded performance. We are currently working to resolve this issue.
Resolved
This incident has been resolved.
Posted 7 days ago. Oct 09, 2018 - 02:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted 7 days ago. Oct 09, 2018 - 02:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 7 days ago. Oct 08, 2018 - 23:01 UTC
This incident affected: SecureAnywhere® DNS Protection.