Degraded Performance- Webroot Security Awareness Training
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 16:38 UTC
Investigating
Webroot Security Awareness Training is experiencing slow and delayed email delivery for the past 48 hours.
We are working to resolve this ASAP.
Posted Aug 11, 2023 - 17:52 UTC
This incident affected: Security Awareness Training.