Degraded mail delivery to domains hosted on google platform

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 16:27 UTC

Identified

The issue has been identified as affecting only mail delivered by SAT to domains hosted on the google platform. All other mail from SAT remains fully operational. A fix is being implemented.
Posted Apr 08, 2025 - 15:57 UTC
This incident affected: Security Awareness Training.