IAD Region: degraded performance
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 13, 2018 - 20:14 UTC
Investigating
The SecureAnywhere® DNS Protection is currently experiencing degraded performance. Customers may notice slower than usual DNS resolution times in the IAD region. We are investigating the issue and will have an update or resolution ASAP.
Posted about 1 month ago. Oct 13, 2018 - 14:07 UTC
This incident affected: DNS Protection.